laptop hell (continued) - no sound

hi guys, thanks for the help on the locked files.

next problem to solve is that I have no sound.

I'm running windows xp professional on a pioneer laptop, with realtek high definition audio as my default device.

the sound went awol when I undid a system restore when trying to solve the locked files problem.

now if I go into device manager I get the error "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)" for the realtek device and for microsoft kernal, and also have errors on all the listed audio and video codecs.

i've tried uninstalling them and rebooting. I've tried downloading a driver from the realtek site. all to no avail.

any ideas?


Unfortunately Microsoft's

Unfortunately Microsoft's description of code 39 only has advice you've probably already covered - but here it is just in case.

Reasons for this error include a driver that is not present; a binary file that is corrupted; a file I/O problem, or a driver that references an entry point in another binary file that could not be loaded.

Uninstall the driver, and then click Scan for hardware changes to reinstall or upgrade the driver.

On the General Properties tab of the device, click Troubleshoot to start the Troubleshooting Wizard.

I did hear of one person with this sort of problem who had inadvertently downloaded the "normal" Realtek drivers from their website. There are apparently special specific high definition HD drivers which would be the ones that should work - give them a go if you haven't tried them (after uninstalling any other drivers and deleting the offending items out of device manager).

If you've already done these things I'm a bit lost for now other than to suggest restoring your system to factory configuration if possible but that is a proper annoyance at this stage as you'll have to restore all your documents, programs etc. after doing it!

answer - grow up and use

answer - grow up and use Linux..

still screwed

still no sound :(

I am running Vista with the

I am running Vista with the same drivers (RealTek High def) and have no audio in the internet browser.

I have tried:

adding a value in regedit as suggested on another forum
uninstalling and reinstalling the drivers
loading garageband (apparently that worked for some)

all settings appear correct and I get audio for things like messenger opening.

I am computer illiterate when it comes to tech stuff. Please can someone suggest a fix for me.

Thanks in advance

That is a weird one - I

That is a weird one - I couldn't understand why sound would work elsewhere but not on the Internet. I can't really think of anything other than what other pages on the Internet are saying. Are you using Internet Explorer? If so and you haven't already check out these links and see if they help - but really I think they are for Windows XP rather than Vista so am not sure if they are relevant (I've never used Vista).

No sound in Internet Explorer
Internet Explorer 6 nightmares

Maybe you could try using a different web browser if you haven't already just to see if it works in that? e.g. Firefox

hi

Topic is very informative. Thanks.

try this

Goed artikel, ik heb deze blog opgenomen op mij iGoogle! fake watches

the third 'anonymous' post is not by me!

the fourth 'anonymous' post is not by me! (only the first and third are mine)

I'm running XP, not vista, and I have no sound anywhere on my computer at all!

I've tried uninstalling and reinstalling drivers from the laptop manufacturer site and the soundcard manufacturer site - no luck

"troubleshooting" can't even find the device driver

please, please any other suggestions?

Sorry, I posted the

Sorry, I posted the anonymous anonymous post. I too am struggling with soundless internet. I have a built in RealTek sound card and cannot figure out how to fix it.

Doing my head in!

fixing the sound

hi,
we get this one a lot, it has the same sympotm as yours.
you have to go into device manager
remove the sound devices (or unknown devices, or both)
restart the laptop
cancel the found new hardware wizard
install the realtek drivers using the exe (not the inf)
restart
let it detect (if you uninstalled too many things in step one)
and off you go

the trick is
YOU MUST DO ALL OF THIS AS THE LOCAL ADMINISTRATOR
not as someone local on the machine who has admin rights, but actually log on as Administrator
and not administrator for the domain, you must log on as administrator, you must log on to the local machine.
then it should work.

good luck!

if that doens't fix it, ask in annoyances.org

sorry, this fix is for XP. perhaps it works for vista...

sorry, this fix is for XP. perhaps it works for vista...

Post new comment

The content of this field is kept private and will not be shown publicly.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <blockquote> <del> <p>
  • Lines and paragraphs break automatically.
  • You may post code using <code>...</code> (generic) or <?php ... ?> (highlighted PHP) tags.
  • You may use [acidfree:xx] tags to display acidfree videos or images inline.
  • Images can be added to this post.

More information about formatting options

CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions.
6 + 0 =
Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.